RSS

  • YouTube
  • LinkedIn
  • Google

Archives for : Postfix

How to clear deferred messages from Postfix Queue

Today I was watching the log file from Postfix (in CentOS 6.X default is /var/log/maillog) and saw a lot of messages being deferred.

and these messages did repeat from time to time.

Continue Reading >>

Error when starting Amavisd-new

Two days ago I'm trying to install the software for my new server that will host this blog, my personal projects and my e-mail server.
I'm using as a base this HOWTO.

I had a lot of problems in installation and in particular an error when starting Amavisd-new

Googando I saw different ways to solve and no work. That's when I realized something silly, but that's making perfect sense. The packages mentioned, Perl-Mail-DKIM and perl-Crypt-OpenSSL-RSA., pointed to EL5 while the package Amavis pointed to EL6.
Checked that the DAG of rpmforge was using EL5 and correct for my Centos 6.3 was to use the DAG EL6. To correct this item and update packages, VOI-la. Everything worked beautifully.

Follow the steps to the fix

first import the key for the repository
rpm --import http://apt.sw.be/RPM-GPG-KEY.dag.txt
Then uninstall the current (use yum search rpmforge-release to find out the correct name of the package), Download the RPM file and make the installation.

> yum remove rpmforge-release-0.5.2-2.el5.rf.x86_64
> wget http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.2-2.el6.rf.x86_64.rpm
> rpm -i rpmforge-release-0.5.2-2.el6.rf.x86_64.rpm

The last step is to synchronize the distribution, that will cause the packages to be replaced by existing in EL5 EL6.
> yum distribution-synchronization

From this point, If there is already done the installation of all packages previously, they should not show this error.

I hope it helped you.

Useful links
http://wiki.centos.org/AdditionalResources/Repositories/RPMForge#head-f0c3ecee3dbb407e4eed79a56ec0ae92d1398e01