RSS

  • YouTube
  • LinkedIn
  • Google

Archivos de la : January2013

Error al iniciar Amavisd-new

Hace dos días estoy tratando de instalar el software para mi nuevo servidor que será el anfitrión de este blog, mis proyectos personales y mi servidor de correo electrónico.
Estoy usando como base este HOWTO.

Tuve muchos problemas en la instalación y en particular un error al iniciar Amavisd-new

Googando vi diferentes maneras de resolver y sin trabajo. Es entonces cuando me di cuenta de algo tonto, pero hace sentido perfecto. Los paquetes mencionados, Perl-correo-DKIM e perl-cripta-OpenSSL-RSA., señaló EL5 mientras que el paquete de Amavis señaló EL6.
Comprobar que el DAG de rpmforge usando EL5 y corregir mi Centos 6.3 era utilizar el EL6 DAG. Para corregir este artículo y actualizar paquetes, VOI-la. Todo funcionó muy bien.

Siga los pasos para la solución

importar primero la clave del repositorio
rpm --import http://apt.sw.be/RPM-GPG-KEY.dag.txt
Desinstale la actual (usar yum search rpmforge-release para averiguar el nombre correcto del paquete), Descargar el archivo RPM y hacer la instalación.

> yum remove rpmforge-release-0.5.2-2.el5.rf.x86_64
> wget http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.2-2.el6.rf.x86_64.rpm
> rpm -i rpmforge-release-0.5.2-2.el6.rf.x86_64.rpm

El último paso es sincronizar la distribución, hará que los paquetes ser reemplazado por existentes en EL5 EL6.
> yum distribution-synchronization

Desde este punto, Si allí ya se ha hecho la instalación de todos los paquetes previamente, no debe mostrar este error.

Espero que te ayudado.

Enlaces útiles
http://wiki.centos.org/AdditionalResources/Repositories/RPMForge#head-f0c3ecee3dbb407e4eed79a56ec0ae92d1398e01