FLUX RSS

  • YouTube
  • LinkedIn
  • Google

Archives pour : janeiro2013

Erreur lors du démarrage de Amavisd-new

Há dois dias estou tentando instalar os softwares para meu novo servidor que abrigará este blog, mes projets personnels et mon serveur de messagerie.
J'utilise comme base ce HOWTO.

Tive muitos problemas na instalação e em especial um erro ao iniciar o Amavisd-new

Problème à Amavis::Code de DKIM: Impossible de trouver Crypt/OpenSSL/RSA.pm dans @INC

Googando que j'ai vu différentes manières de résoudre et aucun travail. C'est quand j'ai réalisé quelque chose de stupide, mais qui fait tout son sens. Les forfaits mentionnés, DKIM-Mail-Perl et perl-crypte-OpenSSL-RSA., a souligné les EL5 mais le paquet Amavis a souligné EL6.
Vérifié que le DAG de rpmforge utilisait EL5 et corriger mon Centos 6.3 était d'utiliser le DAG EL6. Pour corriger ce point et les packages de correctifs, VOI-la. Tout a fonctionné à merveille.

Segue os passos para a correção

tout d'abord importer la clé pour le référentiel
rpm --import http://apt.sw.be/RPM-GPG-KEY.dag.txt
Puis désinstallez le courant (yum search rpmforge libération permet de trouver le nom exact du paquet), baixe o arquivo RPM e o faça a instalação.

> yum remove rpmforge-release-0.5.2-2.el5.rf.x86_64
> wget http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.2-2.el6.rf.x86_64.rpm
> rpm -i rpmforge-release-0.5.2-2.el6.rf.x86_64.rpm

O ultimo passo é sincronizar a distribuição, que fará com que os pacotes EL5 sejam substituídos por existentes em EL6.
> yum distribution-synchronization

De ce point, se já houver feito a instalação dos pacotes todos anteriormente, eles já não devem apresentar mais esse erro.

J'espère que cela vous a aidé.

Liens utiles
http://wiki.centos.org/AdditionalResources/Repositories/RPMForge#head-f0c3ecee3dbb407e4eed79a56ec0ae92d1398e01